RepositoryGo
QU

quic-go/quic-go

A production-ready QUIC implementation in pure Go

11.8ksao
1.7kfork
167issue
2lượt xem

Thành tựu nổi bật

Những danh hiệu mới nhất của dự án

1
TINIX TRENDING·Chủ đề: quic-client

#1 Repository Của Tuần

1
TINIX TRENDING·Chủ đề: qlog

#1 Repository Của Tuần

1
TINIX TRENDING·Chủ đề: quic-server

#1 Repository Của Tuần

🚀 quic-go: QUIC & HTTP/3 trong Go, không phụ thuộc bên ngoài

Implement đầy đủ RFC 9000/9001/9002 + HTTP/3 bằng Go nguyên sách.

quic-go là một thư viện Go thuần sạch (pure Go) cài đặt giao thức QUIC theo các RFC 9000, 9001, 9002, kèm hỗ trợ HTTP/3 (RFC 9114), QPACK (RFC 9204) và HTTP Datagrams (RFC 9297). Ngoài ra còn hỗ trợ WebTransport qua dự án riêng webtransport-go.

✨ Điểm nổi bật

  • Hỗ trợ chuẩn QUIC/HTTP3: Tích hợp RFC 9000–9002, HTTP/3, QPACK, HTTP Datagrams.
  • Mở rộng RFC khác: Unreliable Datagram (RFC 9221), DPLPMTUD (RFC 8899), QUIC v2 (RFC 9369), qlog logging.
  • FIPS 140-3: Từ v0.60, hỗ trợ môi trường FIPS khi dùng Go 1.26+.
  • Được dự án lớn dùng: Caddy, Cloudflare, IPFS/Kubo, frp, Hysteria, v.v.
  • Độ phủ kiểm thử cao: Được theo dõi bởi fuzzing OSS-Fuzz.
  • Tài liệu chi tiết: Truy cập https://quic-go.net/docs/ để biết thêm.

💡 Vì sao đáng chú ý

Không như các thư viện QUIC khác dựa trên OpenSSL hay C bindings, quic-go hoạt động hoàn toàn bằng Go, dễ dàng tích hợp và triển khai. Đặc biệt, sự hỗ trợ FIPS giúp nó phù hợp với môi trường doanh nghiệp yêu cầu tuân thủ tiêu chuẩn mật mã.


#QUIC #HTTP3 #GoLang #Networking #TiniX

Dự án tương tự

Khám phá các dự án và mô hình AI khác có sự tương đồng.

RepositoryGo
avelino/awesome-go

A curated list of awesome Go frameworks, libraries and software

191.0k
Oct 26, 2026
RepositoryGo
ollama/ollama

Get up and running with Kimi, GLM, MiniMax, DeepSeek, gpt-oss, Qwen, Gemma and other models.

185.2k
Oct 29, 2026
RepositoryRust
cloudflare/quiche

🥧 Savoury implementation of the QUIC transport protocol and HTTP/3

12.8k
Oct 27, 2026
RepositoryC
alibaba/xquic

XQUIC Library released by Alibaba is a cross-platform implementation of QUIC and HTTP/3 protocol.

1.9k
Oct 27, 2026
RepositoryC
litespeedtech/lsquic

LiteSpeed QUIC and HTTP/3 Library

1.9k
Oct 25, 2026
RepositoryRust
Tencent/tquic

A high-performance, lightweight, and cross-platform QUIC library

1.4k
Oct 8, 2026
RepositoryGo
golang/go

The Go programming language

139.5k
Oct 28, 2026
RepositoryPython
practical-tutorials/project-based-learning

Curated list of project-based tutorials

288.4k
Oct 26, 2026
RepositoryGo
moby/moby

The Moby Project - a collaborative project for the container ecosystem to assemble container-based systems

72.2k
Oct 27, 2026