RepositoryC
NG

ngtcp2/ngtcp2

ngtcp2 project is an effort to implement IETF QUIC protocol

1.5kstars
308forks
2issues
3views

Thành tựu nổi bật

Những danh hiệu mới nhất của dự án

1
TINIX TRENDING·Chủ đề: rfc9001

#1 Repository Của Tuần

1
TINIX TRENDING·Chủ đề: rfc9002

#1 Repository Của Tuần

1
TINIX TRENDING·Chủ đề: rfc9287

#1 Repository Của Tuần

🚀 ngtcp2 — Bộ cài tham chiếu QUIC của IETF bằng ngôn ngữ C

ngtcp2 cài đặt trọn giao thức QUIC theo chuẩn RFC 9000, RFC 9001, RFC 9002, RFC 9221, RFC 9287.

ngtcp2 là dự án mã nguồn mở cài đặt giao thức QUIC theo chuẩn IETF (RFC 9000 trở lên), viết bằng ngôn ngữ C và không phụ thuộc thư viện bên ngoài cho lõi thư viện libngtcp2. Dự án cung cấp ví dụ client/server bằng C++23 và tích hợp hỗ trợ HTTP/3 thông qua thư viện nghttp3.

✨ Điểm nổi bật

  • Tuân thủ RFC: Hỗ trợ đầy đủ QUIC theo RFC 9000, 9001, 9002, 9221, 9287.
  • Độc lập thư viện: libngtcp2 không cần bất kỳ thư viện bên ngoài nào.
  • Hỗ trợ HTTP/3: Tích hợp với nghttp3 để cung cấp khả năng HTTP/3.
  • Đa dạng TLS backend: Hỗ trợ BoringSSL, aws-lc, GnuTLS, wolfSSL, LibreSSL, OpenSSL, Picotls.
  • Server thử nghiệm công cộng: Cung cấp endpoint tại https://nghttp2.org:4433 để kiểm tra.
  • Hỗ trợ TLS Certificate Compression: Tích hợp RFC 8879 trong ví dụ BoringSSL.
  • Hệ thống build chuẩn: Sử dụng autoconf/automake/libtool.

💡 Vì sao đáng chú ý

Khác với các dự án QUIC khác thường dựa vào một backend TLS duy nhất, ngtcp2 hỗ trợ nhiều backend TLS phổ biến, giúp dễ dàng tích hợp vào các hệ sinh thái khác nhau. Đặc biệt, dự án cung cấp server thử nghiệm công cộng, cho phép mọi người trải nghiệm HTTP/3 ngay lập tức.


#QUIC #HTTP3 #Networking #OpenSource #TiniX

Similar Projects

Discover other similar projects and AI models.

RepositoryC
skywind3000/kcp

:zap: KCP - A Fast and Reliable ARQ Protocol

16.9k
Jun 23, 2026
RepositoryC
litespeedtech/lsquic

LiteSpeed QUIC and HTTP/3 Library

1.9k
Oct 25, 2026
RepositoryRust
Tencent/tquic

A high-performance, lightweight, and cross-platform QUIC library

1.4k
Oct 8, 2026
RepositoryC
microsoft/msquic

Cross-platform, C implementation of the IETF QUIC protocol, exposed to C, C++, C# and Rust.

4.8k
Oct 24, 2026
RepositoryC
mas-bandwidth/netcode

Secure client/server protocol for multiplayer games built on top of UDP

2.6k
Oct 22, 2026
RepositoryC
alibaba/xquic

XQUIC Library released by Alibaba is a cross-platform implementation of QUIC and HTTP/3 protocol.

1.9k
Oct 27, 2026
RepositoryRust
cloudflare/quiche

🥧 Savoury implementation of the QUIC transport protocol and HTTP/3

12.8k
Oct 27, 2026
RepositoryGo
quic-go/quic-go

A production-ready QUIC implementation in pure Go

11.8k
Oct 27, 2026
RepositoryC#
MirrorNetworking/Mirror

#1 Open Source Unity Networking Library

6.4k
Oct 19, 2026